summaryrefslogtreecommitdiffstats
path: root/package/grep
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:56 +0000
commit627d2ec9e67cd405103c3567964bf72a90e658fd (patch)
tree525038eae6a5f02d9292397def2697db48220906 /package/grep
parent9a1526d7d9474a5b3a43f0c0e453f431428fafcc (diff)
downloadbuildroot-novena-627d2ec9e67cd405103c3567964bf72a90e658fd.tar.gz
buildroot-novena-627d2ec9e67cd405103c3567964bf72a90e658fd.zip
grep: fix target install and clean
Diffstat (limited to 'package/grep')
-rw-r--r--package/grep/grep.mk19
1 files changed, 7 insertions, 12 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index 0e99698e0..a7affa573 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -58,21 +58,16 @@ $(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
$(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
$(MAKE) -C $(GNUGREP_DIR)
-# This stuff is needed to work around GNU make deficiencies
-grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
- @if [ -L $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) ]; then \
- rm -f $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY); fi
- @if [ ! -f $(GNUGREP_DIR)/$(GNUGREP_BINARY) -o $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) -ot \
- $(GNUGREP_DIR)/$(GNUGREP_BINARY) ]; then \
- set -x; \
- rm -f $(TARGET_DIR)/bin/grep $(TARGET_DIR)/bin/egrep $(TARGET_DIR)/bin/fgrep; \
- cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
- $(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
+$(TARGET_DIR)/$(GNUGREP_TARGET_BINARY): $(GNUGREP_DIR)/$(GNUGREP_BINARY)
+ for i in egrep fgrep grep; do \
+ $(INSTALL) $(GNUGREP_DIR)/src/$$i $(@D); \
+ done
+ $(STRIPCMD) $(STRIP_STRIP_ALL) $@
-grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY)
grep-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall
+ rm -f $(addprefix $(TARGET_DIR)/bin/,egrep fgrep grep)
-$(MAKE) -C $(GNUGREP_DIR) clean
grep-dirclean: