summaryrefslogtreecommitdiffstats
path: root/package/git
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-03 22:52:24 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-03 22:52:24 +0200
commit34dae9ac288031f869ae808ebd70b2d965b3df3d (patch)
treed91290f6a8808d1e984abe7fb2e04c8dcfe62e0b /package/git
parentf7dbc3a50061249a14d04627b9659304ebd1ea8c (diff)
downloadbuildroot-novena-34dae9ac288031f869ae808ebd70b2d965b3df3d.tar.gz
buildroot-novena-34dae9ac288031f869ae808ebd70b2d965b3df3d.zip
git: needs libiconv on toolchains without locale support
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/git')
-rw-r--r--package/git/Config.in1
-rw-r--r--package/git/git.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/package/git/Config.in b/package/git/Config.in
index dc342aa7b..931d460d4 100644
--- a/package/git/Config.in
+++ b/package/git/Config.in
@@ -2,6 +2,7 @@ config BR2_PACKAGE_GIT
bool "git"
depends on BR2_LARGEFILE
select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
help
Git is a free and open source distributed version control system
designed to handle everything from small to very large projects.
diff --git a/package/git/git.mk b/package/git/git.mk
index 6bc976149..7e2f114be 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -40,6 +40,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBICONV),y)
GIT_DEPENDENCIES += libiconv
+ GIT_CONF_ENV += LIBS=-liconv
GIT_CONF_OPT += --with-iconv=/usr/lib
else
GIT_CONF_OPT += --without-iconv
@@ -54,7 +55,7 @@ endif
# assume yes for these tests, configure will bail out otherwise
# saying error: cannot run test program while cross compiling
-GIT_CONF_ENV = ac_cv_fread_reads_directories=yes \
+GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
ac_cv_snprintf_returns_bogus=yes
$(eval $(autotools-package))