summaryrefslogtreecommitdiffstats
path: root/package/git/git.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/git/git.mk')
-rw-r--r--package/git/git.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/git/git.mk b/package/git/git.mk
index 6bc976149..7e2f114be 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -40,6 +40,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBICONV),y)
GIT_DEPENDENCIES += libiconv
+ GIT_CONF_ENV += LIBS=-liconv
GIT_CONF_OPT += --with-iconv=/usr/lib
else
GIT_CONF_OPT += --without-iconv
@@ -54,7 +55,7 @@ endif
# assume yes for these tests, configure will bail out otherwise
# saying error: cannot run test program while cross compiling
-GIT_CONF_ENV = ac_cv_fread_reads_directories=yes \
+GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
ac_cv_snprintf_returns_bogus=yes
$(eval $(autotools-package))