summaryrefslogtreecommitdiffstats
path: root/package/fmtools
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2012-04-01 14:18:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-08 09:41:58 +0200
commitacf7bb7217d7de6981909112bdbd2af1faf680b5 (patch)
tree67aab8f29ad0e3a08f2e5cf3517be88941c265d9 /package/fmtools
parent0b9eb5713d971cb9af7c75e92a9647e0fd449a9e (diff)
downloadbuildroot-novena-acf7bb7217d7de6981909112bdbd2af1faf680b5.tar.gz
buildroot-novena-acf7bb7217d7de6981909112bdbd2af1faf680b5.zip
package: add fmtools
[Peter: fix install, help text] Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fmtools')
-rw-r--r--package/fmtools/Config.in9
-rw-r--r--package/fmtools/fmtools.mk19
2 files changed, 28 insertions, 0 deletions
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644
index 000000000..159161889
--- /dev/null
+++ b/package/fmtools/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_FMTOOLS
+ bool "fmtools"
+ help
+ fmtools is a pair of simple command-line utilities for
+ "video4linux" radio tuner cards under Linux. It includes
+ fm for power control, tuning, and volume and fmscan for
+ scanning for stations.
+
+ http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644
index 000000000..f705173ec
--- /dev/null
+++ b/package/fmtools/fmtools.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin/fm
+ $(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin/fmscan
+endef
+
+$(eval $(call GENTARGETS))