summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/fmtools/Config.in9
-rw-r--r--package/fmtools/fmtools.mk19
3 files changed, 29 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index c895cc14a..4c6d4d87f 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -174,6 +174,7 @@ source "package/e2fsprogs/Config.in"
source "package/eeprog/Config.in"
source "package/fconfig/Config.in"
source "package/fis/Config.in"
+source "package/fmtools/Config.in"
source "package/gadgetfs-test/Config.in"
source "package/gdisk/Config.in"
source "package/genext2fs/Config.in"
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644
index 000000000..159161889
--- /dev/null
+++ b/package/fmtools/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_FMTOOLS
+ bool "fmtools"
+ help
+ fmtools is a pair of simple command-line utilities for
+ "video4linux" radio tuner cards under Linux. It includes
+ fm for power control, tuning, and volume and fmscan for
+ scanning for stations.
+
+ http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644
index 000000000..f705173ec
--- /dev/null
+++ b/package/fmtools/fmtools.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin/fm
+ $(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin/fmscan
+endef
+
+$(eval $(call GENTARGETS))