summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorAlexander Clouter <alex@digriz.org.uk>2011-05-16 22:41:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-16 22:41:54 +0200
commita7e78f974e4536c23904cb5714ce1a917b3f420e (patch)
treeef612f795cf978d56e824884352932e736e37cca /package/dropbear
parent017e3061fdd62d42ffb851057b67e6d96b1fd47a (diff)
downloadbuildroot-novena-a7e78f974e4536c23904cb5714ce1a917b3f420e.tar.gz
buildroot-novena-a7e78f974e4536c23904cb5714ce1a917b3f420e.zip
dropbear: disable zlib support when built with small option
Closes #3733 Signed-off-by: Alexander Clouter <alex@digriz.org.uk> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Config.in4
-rw-r--r--package/dropbear/dropbear.mk3
2 files changed, 4 insertions, 3 deletions
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
index 4bc0e3e1b..c30228f20 100644
--- a/package/dropbear/Config.in
+++ b/package/dropbear/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_DROPBEAR
bool "dropbear"
- select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_ZLIB if !BR2_PACKAGE_DROPBEAR_SMALL
help
A small SSH 2 server designed for small memory environments.
@@ -22,4 +22,4 @@ config BR2_PACKAGE_DROPBEAR_SMALL
Compile dropbear for the smallest possible binary size.
Tradeoffs are slower hashes and ciphers, and disabling of the
- blowfish cipher.
+ blowfish cipher and zlib.
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index d73e99346..6ef5dec44 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -7,7 +7,6 @@
DROPBEAR_VERSION = 0.53.1
DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.gz
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
-DROPBEAR_DEPENDENCIES = zlib
DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
DROPBEAR_MAKE = $(MAKE) MULTI=1 SCPPROGRESS=1 \
PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
@@ -41,8 +40,10 @@ endif
ifeq ($(BR2_PACKAGE_DROPBEAR_SMALL),y)
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_SMALL
+DROPBEAR_CONF_OPT += --disable-zlib
else
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
+DROPBEAR_DEPENDENCIES += zlib
endif
define DROPBEAR_INSTALL_TARGET_CMDS