summaryrefslogtreecommitdiffstats
path: root/package/dropbear/dropbear.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/dropbear/dropbear.mk')
-rw-r--r--package/dropbear/dropbear.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index d73e99346..6ef5dec44 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -7,7 +7,6 @@
DROPBEAR_VERSION = 0.53.1
DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.gz
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
-DROPBEAR_DEPENDENCIES = zlib
DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
DROPBEAR_MAKE = $(MAKE) MULTI=1 SCPPROGRESS=1 \
PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
@@ -41,8 +40,10 @@ endif
ifeq ($(BR2_PACKAGE_DROPBEAR_SMALL),y)
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_SMALL
+DROPBEAR_CONF_OPT += --disable-zlib
else
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
+DROPBEAR_DEPENDENCIES += zlib
endif
define DROPBEAR_INSTALL_TARGET_CMDS