summaryrefslogtreecommitdiffstats
path: root/package/bison
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/bison
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
downloadbuildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.tar.gz
buildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.zip
facelift step number two
Diffstat (limited to 'package/bison')
-rw-r--r--package/bison/bison.mk2
-rwxr-xr-xpackage/bison/yacc2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/bison/bison.mk b/package/bison/bison.mk
index 89c9b916c..7481b7688 100644
--- a/package/bison/bison.mk
+++ b/package/bison/bison.mk
@@ -49,7 +49,7 @@ $(TARGET_DIR)/$(BISON_TARGET_BINARY): $(BISON_DIR)/$(BISON_BINARY)
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) install
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
- cp -a $(SOURCE_DIR)/yacc $(TARGET_DIR)/usr/bin/yacc
+ cp -a package/bison/yacc $(TARGET_DIR)/usr/bin/yacc
bison: uclibc $(TARGET_DIR)/$(BISON_TARGET_BINARY)
diff --git a/package/bison/yacc b/package/bison/yacc
new file mode 100755
index 000000000..aed120e88
--- /dev/null
+++ b/package/bison/yacc
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/bison -y "$@"