summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-04 16:13:08 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-04 16:13:08 +0000
commit30e43682dd8ad07a0f60f8035e28ab5c6d4ac466 (patch)
tree2e6e37fde15a3441b299a386b6350aa1e3fa24a1 /package/avahi
parentf974e39491273737c0599a9d98442885ffa13b5b (diff)
downloadbuildroot-novena-30e43682dd8ad07a0f60f8035e28ab5c6d4ac466.tar.gz
buildroot-novena-30e43682dd8ad07a0f60f8035e28ab5c6d4ac466.zip
avahi: add dependency to host-autoconf
Avahi uses autoconf during ./configure, make sure it is available and used before building avahi. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 32d266a57..0746a047a 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -53,7 +53,7 @@ $(AVAHI_DIR)/.unpacked: $(DL_DIR)/$(AVAHI_SOURCE)
touch $@
$(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked $(AVAHI_EXTRA_DEPS)
- (cd $(AVAHI_DIR) && rm -rf config.cache && autoconf)
+ (cd $(AVAHI_DIR) && rm -rf config.cache && PATH=$(TARGET_PATH) autoconf)
(cd $(AVAHI_DIR) && \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
@@ -180,7 +180,7 @@ endif
$(TARGET_DIR)/usr/sbin/avahi-daemon
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-avahi: uclibc libdaemon $(if $(BR2_ENABLE_LOCALE),gettext libintl) $(AVAHI_TARGETS)
+avahi: host-autoconf uclibc libdaemon $(if $(BR2_ENABLE_LOCALE),gettext libintl) $(AVAHI_TARGETS)
avahi-clean:
-$(MAKE) -C $(AVAHI_DIR) distclean