summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 32d266a57..0746a047a 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -53,7 +53,7 @@ $(AVAHI_DIR)/.unpacked: $(DL_DIR)/$(AVAHI_SOURCE)
touch $@
$(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked $(AVAHI_EXTRA_DEPS)
- (cd $(AVAHI_DIR) && rm -rf config.cache && autoconf)
+ (cd $(AVAHI_DIR) && rm -rf config.cache && PATH=$(TARGET_PATH) autoconf)
(cd $(AVAHI_DIR) && \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
@@ -180,7 +180,7 @@ endif
$(TARGET_DIR)/usr/sbin/avahi-daemon
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-avahi: uclibc libdaemon $(if $(BR2_ENABLE_LOCALE),gettext libintl) $(AVAHI_TARGETS)
+avahi: host-autoconf uclibc libdaemon $(if $(BR2_ENABLE_LOCALE),gettext libintl) $(AVAHI_TARGETS)
avahi-clean:
-$(MAKE) -C $(AVAHI_DIR) distclean