summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-27 07:29:20 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-27 07:29:20 +0000
commitbe8ad23b096707b9a877525815c755c7f5d368bc (patch)
tree786d973994dd5b2cc4f164e4fc766814b85f91a7 /package/avahi/avahi.mk
parent73ec8a1d7e81533dce71936ae922d38da404de99 (diff)
downloadbuildroot-novena-be8ad23b096707b9a877525815c755c7f5d368bc.tar.gz
buildroot-novena-be8ad23b096707b9a877525815c755c7f5d368bc.zip
avahi: fix build with BR2_ENABLE_LOCALE
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 6c25b36ec..2d95e933d 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -142,7 +142,7 @@ $(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked $(AVAHI_EXTRA_DEPS)
touch $@
$(AVAHI_DIR)/.compiled: $(AVAHI_DIR)/.configured
- $(MAKE) -C $(AVAHI_DIR)
+ $(MAKE) -C $(AVAHI_DIR) $(if $(BR2_ENABLE_LOCALE),LIBS=-lintl)
touch $@
$(AVAHI_DIR)/.installed: $(AVAHI_DIR)/.compiled
@@ -180,7 +180,7 @@ endif
$(TARGET_DIR)/usr/sbin/avahi-daemon
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-avahi: uclibc libdaemon $(AVAHI_TARGETS)
+avahi: uclibc libdaemon $(AVAHI_TARGETS) $(if $(BR2_ENABLE_LOCALE),gettext libintl)
avahi-clean:
-$(MAKE) -C $(AVAHI_DIR) distclean