summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-27 07:29:20 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-27 07:29:20 +0000
commitbe8ad23b096707b9a877525815c755c7f5d368bc (patch)
tree786d973994dd5b2cc4f164e4fc766814b85f91a7 /package/avahi
parent73ec8a1d7e81533dce71936ae922d38da404de99 (diff)
downloadbuildroot-novena-be8ad23b096707b9a877525815c755c7f5d368bc.tar.gz
buildroot-novena-be8ad23b096707b9a877525815c755c7f5d368bc.zip
avahi: fix build with BR2_ENABLE_LOCALE
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/Config.in2
-rw-r--r--package/avahi/avahi.mk4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/avahi/Config.in b/package/avahi/Config.in
index 245ff3669..403680186 100644
--- a/package/avahi/Config.in
+++ b/package/avahi/Config.in
@@ -1,6 +1,8 @@
config BR2_PACKAGE_AVAHI
bool "avahi"
select BR2_PACKAGE_LIBDAEMON
+ select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+ select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
help
Avahi is a system which facilitates service
discovery on a local network.
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 6c25b36ec..2d95e933d 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -142,7 +142,7 @@ $(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked $(AVAHI_EXTRA_DEPS)
touch $@
$(AVAHI_DIR)/.compiled: $(AVAHI_DIR)/.configured
- $(MAKE) -C $(AVAHI_DIR)
+ $(MAKE) -C $(AVAHI_DIR) $(if $(BR2_ENABLE_LOCALE),LIBS=-lintl)
touch $@
$(AVAHI_DIR)/.installed: $(AVAHI_DIR)/.compiled
@@ -180,7 +180,7 @@ endif
$(TARGET_DIR)/usr/sbin/avahi-daemon
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-avahi: uclibc libdaemon $(AVAHI_TARGETS)
+avahi: uclibc libdaemon $(AVAHI_TARGETS) $(if $(BR2_ENABLE_LOCALE),gettext libintl)
avahi-clean:
-$(MAKE) -C $(AVAHI_DIR) distclean