summaryrefslogtreecommitdiffstats
path: root/package/am33x-cm3
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-09 00:57:38 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-09 20:59:14 +0200
commitc73c5fc90d0d40c86ea7690e23fa34409c39f4bf (patch)
treea50abc710372e6090e0de73a25ef9419ac7a86ca /package/am33x-cm3
parent1d0f68f4767df9bc79c206ec03314e60ffa4e7eb (diff)
downloadbuildroot-novena-c73c5fc90d0d40c86ea7690e23fa34409c39f4bf.tar.gz
buildroot-novena-c73c5fc90d0d40c86ea7690e23fa34409c39f4bf.zip
am33x-cm3: Enforce correct -march option
Buildroot uses a normal ARM compiler to build the AM33X CM3 firmware (which runs on a Cortex-M3 processor), but Buildroot will have a default -march value that doesn't necessarily match the one needed for Cortex-M3, leading to build failures (gcc complains that the -mcpu=cortex-m3 option being passed is not compatible with the selected -march). Fix this by explicitly indicating -march=armv7-m. Fixes: http://autobuild.buildroot.net/results/db1/db13623b1701bfe678c302e8f88c7473cb2345f9/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/am33x-cm3')
-rw-r--r--package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch b/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch
new file mode 100644
index 000000000..77ba11c77
--- /dev/null
+++ b/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch
@@ -0,0 +1,26 @@
+Enforce correct -march option
+
+Buildroot uses a normal ARM compiler to build the AM33X CM3 firmware
+(which runs on a Cortex-M3 processor), but Buildroot will have a
+default -march value that doesn't necessarily match the one needed for
+Cortex-M3, leading to build failures (gcc complains that the
+-mcpu=cortex-m3 option being passed is not compatible with the
+selected -march).
+
+Fix this by explicitly indicating -march=armv7-m.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@
+ BINDIR = bin
+
+ INCLUDES = $(SRCDIR)/include
+-CFLAGS =-mcpu=cortex-m3 -mthumb -nostdlib -Wall -g -I$(INCLUDES)
++CFLAGS =-march=armv7-m -mcpu=cortex-m3 -mthumb -nostdlib -Wall -g -I$(INCLUDES)
+ LDFLAGS =-nostartfiles -fno-exceptions -Tfirmware.ld
+
+ EXECUTABLE=am335x-pm-firmware.elf