summaryrefslogtreecommitdiffstats
path: root/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch')
-rw-r--r--package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch b/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch
new file mode 100644
index 000000000..77ba11c77
--- /dev/null
+++ b/package/am33x-cm3/am33x-cm3-0001-fix-makefile.patch
@@ -0,0 +1,26 @@
+Enforce correct -march option
+
+Buildroot uses a normal ARM compiler to build the AM33X CM3 firmware
+(which runs on a Cortex-M3 processor), but Buildroot will have a
+default -march value that doesn't necessarily match the one needed for
+Cortex-M3, leading to build failures (gcc complains that the
+-mcpu=cortex-m3 option being passed is not compatible with the
+selected -march).
+
+Fix this by explicitly indicating -march=armv7-m.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@
+ BINDIR = bin
+
+ INCLUDES = $(SRCDIR)/include
+-CFLAGS =-mcpu=cortex-m3 -mthumb -nostdlib -Wall -g -I$(INCLUDES)
++CFLAGS =-march=armv7-m -mcpu=cortex-m3 -mthumb -nostdlib -Wall -g -I$(INCLUDES)
+ LDFLAGS =-nostartfiles -fno-exceptions -Tfirmware.ld
+
+ EXECUTABLE=am335x-pm-firmware.elf