summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-08-28 14:37:00 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-05 22:54:20 +0200
commit5e0d702b7cfa09c9b4b4b0047b10be9f8bbf95a9 (patch)
tree77852900fd27d9cde8bca554f8ce3fc88d8f521a /package/Makefile.in
parentdd00c5fcd072b4a1e3862c5af29f8c580acadd38 (diff)
downloadbuildroot-novena-5e0d702b7cfa09c9b4b4b0047b10be9f8bbf95a9.tar.gz
buildroot-novena-5e0d702b7cfa09c9b4b4b0047b10be9f8bbf95a9.zip
pkg-infra: warn about use of deprecated GENTARGETS
With the replacement of GENTARGETS by package-generic, there is a risk that local packages don't work anymore without any indication of what is wrong. Therefore, generate an error message if the GENTARGETS, AUTOTARGETS or CMAKETARGETS macro is still used. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 340e38799..64508b283 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -300,6 +300,12 @@ else
SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
endif
+# Warn if a package uses the deprecated GENTARGETS macros. This can be
+# removed again for BR-2012.11.
+GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
+AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
+CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
+
include package/pkg-utils.mk
include package/pkg-download.mk
include package/pkg-autotools.mk