summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 340e38799..64508b283 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -300,6 +300,12 @@ else
SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
endif
+# Warn if a package uses the deprecated GENTARGETS macros. This can be
+# removed again for BR-2012.11.
+GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
+AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
+CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
+
include package/pkg-utils.mk
include package/pkg-download.mk
include package/pkg-autotools.mk