summaryrefslogtreecommitdiffstats
path: root/fs/cloop
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/cloop
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/cloop')
-rw-r--r--fs/cloop/Config.in10
-rw-r--r--fs/cloop/cloop.mk13
2 files changed, 23 insertions, 0 deletions
diff --git a/fs/cloop/Config.in b/fs/cloop/Config.in
new file mode 100644
index 000000000..3e01067a1
--- /dev/null
+++ b/fs/cloop/Config.in
@@ -0,0 +1,10 @@
+config BR2_TARGET_ROOTFS_CLOOP
+ bool "cloop root filesystem for the target device"
+ help
+ Build a cloop root filesystem
+
+ cloop is a Linux kernel module that enables compressed
+ loopback filesystem support. With it you can mount a
+ compressed filesystem like a block device and seamlessly
+ decompress its data while accessing it. The majority of the
+ software on an LNX-BBC is accessed in this fashion.
diff --git a/fs/cloop/cloop.mk b/fs/cloop/cloop.mk
new file mode 100644
index 000000000..c1d6abb80
--- /dev/null
+++ b/fs/cloop/cloop.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# Build the compressed loop root filesystem image
+#
+#############################################################
+
+ROOTFS_CLOOP_DEPENDENCIES = host-cloop host-cdrkit
+
+define ROOTFS_CLOOP_CMD
+ $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,cloop)) \ No newline at end of file