summaryrefslogtreecommitdiffstats
path: root/fs/cloop/cloop.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/cloop/cloop.mk')
-rw-r--r--fs/cloop/cloop.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/fs/cloop/cloop.mk b/fs/cloop/cloop.mk
new file mode 100644
index 000000000..c1d6abb80
--- /dev/null
+++ b/fs/cloop/cloop.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# Build the compressed loop root filesystem image
+#
+#############################################################
+
+ROOTFS_CLOOP_DEPENDENCIES = host-cloop host-cdrkit
+
+define ROOTFS_CLOOP_CMD
+ $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,cloop)) \ No newline at end of file