summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-09 12:12:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-13 20:39:47 +0100
commit579fea227394db02916d7487762c79a8e76e8748 (patch)
treee4dc66e966e516f621ebf24d1ea05c6b97f6596e /boot/uboot
parent6649d6da3f36e973e87d8a73c9618b3215e16253 (diff)
downloadbuildroot-novena-579fea227394db02916d7487762c79a8e76e8748.tar.gz
buildroot-novena-579fea227394db02916d7487762c79a8e76e8748.zip
linux, uboot, mxs-bootlets, barebox: avoid double slash in CUSTOM_TARBALL
Closes #5846 The $(dir ...) function leaves a slash at the end, so that the LINUX_SITE variable for a custom tarball ends in a slash. The DOWNLOAD macro adds another slash between SITE and SOURCE, which results in a double slash in the download URL. Fix this by stripping off the final slash from the _SITE in all packages that have a custom tarball. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/uboot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 619f2e1e3..ea77259d1 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -14,7 +14,7 @@ UBOOT_INSTALL_IMAGES = YES
ifeq ($(UBOOT_VERSION),custom)
# Handle custom U-Boot tarballs as specified by the configuration
UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
-UBOOT_SITE = $(dir $(UBOOT_TARBALL))
+UBOOT_SITE = $(patsubst %/,%,$(dir $(UBOOT_TARBALL)))
UBOOT_SOURCE = $(notdir $(UBOOT_TARBALL))
else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL))