summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-09 12:12:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-13 20:39:47 +0100
commit579fea227394db02916d7487762c79a8e76e8748 (patch)
treee4dc66e966e516f621ebf24d1ea05c6b97f6596e /boot
parent6649d6da3f36e973e87d8a73c9618b3215e16253 (diff)
downloadbuildroot-novena-579fea227394db02916d7487762c79a8e76e8748.tar.gz
buildroot-novena-579fea227394db02916d7487762c79a8e76e8748.zip
linux, uboot, mxs-bootlets, barebox: avoid double slash in CUSTOM_TARBALL
Closes #5846 The $(dir ...) function leaves a slash at the end, so that the LINUX_SITE variable for a custom tarball ends in a slash. The DOWNLOAD macro adds another slash between SITE and SOURCE, which results in a double slash in the download URL. Fix this by stripping off the final slash from the _SITE in all packages that have a custom tarball. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/barebox/barebox.mk2
-rw-r--r--boot/mxs-bootlets/mxs-bootlets.mk2
-rw-r--r--boot/uboot/uboot.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 6cc497669..211e06eaf 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -9,7 +9,7 @@ BAREBOX_VERSION = $(call qstrip,$(BR2_TARGET_BAREBOX_VERSION))
ifeq ($(BAREBOX_VERSION),custom)
# Handle custom Barebox tarballs as specified by the configuration
BAREBOX_TARBALL = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_TARBALL_LOCATION))
-BAREBOX_SITE = $(dir $(BAREBOX_TARBALL))
+BAREBOX_SITE = $(patsubst %/,%,$(dir $(BAREBOX_TARBALL)))
BAREBOX_SOURCE = $(notdir $(BAREBOX_TARBALL))
else ifeq ($(BR2_TARGET_BAREBOX_CUSTOM_GIT),y)
BAREBOX_SITE = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_GIT_REPO_URL))
diff --git a/boot/mxs-bootlets/mxs-bootlets.mk b/boot/mxs-bootlets/mxs-bootlets.mk
index 1975d472c..f93ff8179 100644
--- a/boot/mxs-bootlets/mxs-bootlets.mk
+++ b/boot/mxs-bootlets/mxs-bootlets.mk
@@ -6,7 +6,7 @@
ifeq ($(BR2_TARGET_MXS_BOOTLETS_CUSTOM_TARBALL),y)
MXS_BOOTLETS_TARBALL = $(call qstrip,$(BR2_TARGET_MXS_BOOTLETS_CUSTOM_TARBALL_URL))
- MXS_BOOTLETS_SITE = $(dir $(MXS_BOOTLETS_TARBALL))
+ MXS_BOOTLETS_SITE = $(patsubst %/,%,$(dir $(MXS_BOOTLETS_TARBALL)))
MXS_BOOTLETS_SOURCE = $(notdir $(MXS_BOOTLETS_TARBALL))
else ifeq ($(BR2_TARGET_MXS_BOOTLETS_CUSTOM_GIT),y)
MXS_BOOTLETS_SITE = $(BR2_TARGET_MXS_BOOTLETS_CUSTOM_GIT_URL)
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 619f2e1e3..ea77259d1 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -14,7 +14,7 @@ UBOOT_INSTALL_IMAGES = YES
ifeq ($(UBOOT_VERSION),custom)
# Handle custom U-Boot tarballs as specified by the configuration
UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
-UBOOT_SITE = $(dir $(UBOOT_TARBALL))
+UBOOT_SITE = $(patsubst %/,%,$(dir $(UBOOT_TARBALL)))
UBOOT_SOURCE = $(notdir $(UBOOT_TARBALL))
else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL))