summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-12 13:24:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-12 13:25:46 +0200
commitdb86f18ed7ce0659f3eda3b2101c5862f07ac18b (patch)
treef44a3805aab7b7efbe2abbc3503203dbad070b7d
parent8f07a596113f5ae1aea9cefcfa27aeab6b9348e8 (diff)
downloadbuildroot-novena-db86f18ed7ce0659f3eda3b2101c5862f07ac18b.tar.gz
buildroot-novena-db86f18ed7ce0659f3eda3b2101c5862f07ac18b.zip
u-boot: use BR2_TARGET_UBOOT_VERSION instead of BR2_UBOOT_VERSION
In order to be coherent with all other BR2_TARGET_UBOOT_* options. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--boot/u-boot/Config.in2
-rw-r--r--boot/u-boot/u-boot.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/boot/u-boot/Config.in b/boot/u-boot/Config.in
index 00fd03a74..aa680cf3d 100644
--- a/boot/u-boot/Config.in
+++ b/boot/u-boot/Config.in
@@ -37,7 +37,7 @@ config BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION
endif
-config BR2_UBOOT_VERSION
+config BR2_TARGET_UBOOT_VERSION
string
default "2010.03" if BR2_TARGET_UBOOT_2010_03
default "2009.11" if BR2_TARGET_UBOOT_2009_11
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index ee566112f..ad67343a9 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -3,7 +3,7 @@
# U-Boot
#
#############################################################
-U_BOOT_VERSION:=$(call qstrip,$(BR2_UBOOT_VERSION))
+U_BOOT_VERSION:=$(call qstrip,$(BR2_TARGET_UBOOT_VERSION))
U_BOOT_BOARD_NAME:=$(call qstrip,$(BR2_TARGET_UBOOT_BOARDNAME))
# U-Boot may not be selected in the configuration, but mkimage might