summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-20 23:49:45 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-20 23:49:45 +0100
commit2f3c46561e585ba698e73a91bbff03b2e3be411c (patch)
tree53f1475ed097e2d3ea72dcca8ba4b8198f810343
parent14aa5ee54f33d05a0bd01f21635e095ba07f83ec (diff)
downloadbuildroot-novena-2f3c46561e585ba698e73a91bbff03b2e3be411c.tar.gz
buildroot-novena-2f3c46561e585ba698e73a91bbff03b2e3be411c.zip
neon: add optional ssl support
Signed-off-by: Nigel Kukard <nkukard@lbsd.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES5
-rw-r--r--package/neon/Config.in6
-rw-r--r--package/neon/neon.mk6
3 files changed, 15 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 01b25aa31..4d439bceb 100644
--- a/CHANGES
+++ b/CHANGES
@@ -3,8 +3,9 @@
New packages: libcdaudio, libdvdnav, libdvdread, hostapd, tcpreplay
Updated/fixed packages: autoconf, bind, binutils, busybox,
- directfb, gst-plugins-bad, hal, iw, libfuse, libpcap, lighttpd,
- mesa, mpg123, mtd-utils, pcre, qt, sshfs, tremor, u-boot, usbutils
+ directfb, gst-plugins-bad, hal, iw, libfuse, libpcap,
+ lighttpd, mesa, mpg123, mtd-utils, neon, pcre, qt, sshfs,
+ tremor, u-boot, usbutils
Issues resolved (http://bugs.uclibc.org):
diff --git a/package/neon/Config.in b/package/neon/Config.in
index ce72a2fb6..318e4c6a3 100644
--- a/package/neon/Config.in
+++ b/package/neon/Config.in
@@ -12,6 +12,12 @@ config BR2_PACKAGE_NEON_ZLIB
help
build with ZLIB support
+config BR2_PACKAGE_NEON_SSL
+ bool "SSL support"
+ select BR2_PACKAGE_OPENSSL
+ help
+ build with SSL support
+
choice
prompt "XML Support"
default BR2_PACKAGE_NEON_NOXML
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 1f26a0c96..ed5f99968 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -22,6 +22,12 @@ NEON_DEPENDENCIES+=zlib
else
NEON_CONF_OPT+=--without-zlib
endif
+ifeq ($(BR2_PACKAGE_NEON_SSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no