summaryrefslogtreecommitdiffstats
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 1f26a0c96..ed5f99968 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -22,6 +22,12 @@ NEON_DEPENDENCIES+=zlib
else
NEON_CONF_OPT+=--without-zlib
endif
+ifeq ($(BR2_PACKAGE_NEON_SSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no