aboutsummaryrefslogtreecommitdiffstats
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100644
index 0000000..6645545
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,42 @@
+import setuptools
+
+from refcat import __version__
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+ setuptools.setup(
+ name="refcat",
+ version=__version__,
+ author="Martin Czygan",
+ author_email="martin@archive.org",
+ description="Reference data munging utilities",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://git.archive.org/martin/cgraph",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+ python_requires=">=3.6",
+ entry_points={"console_scripts": [
+ "refcat=refcat.cli:main"
+ ]},
+ install_requires=[
+ "dynaconf[ini]",
+ "fuzzycat",
+ "gluish",
+ ],
+ extras_require={"dev": [
+ "ipython",
+ "isort",
+ "mypy",
+ "pylint",
+ "pytest",
+ "pytest-cov",
+ "twine",
+ "yapf",
+ ],},
+ )