summaryrefslogtreecommitdiffstats
path: root/.vim/c-support/codesnippets/Makefile.multi-target.template
diff options
context:
space:
mode:
authorbnewbold <bnewbold@robocracy.org>2010-04-23 01:20:36 -0400
committerbnewbold <bnewbold@robocracy.org>2010-04-23 01:20:36 -0400
commite0cb5545ccb95cbc6cf03fd256cca622f613ecdf (patch)
tree219ab0ba233d717b90b21968acf51454cd6c9dc5 /.vim/c-support/codesnippets/Makefile.multi-target.template
parentf505cc10656d4262dba69aa6ced81dd9024ec592 (diff)
downloadopenwrt-repro-e0cb5545ccb95cbc6cf03fd256cca622f613ecdf.tar.gz
openwrt-repro-e0cb5545ccb95cbc6cf03fd256cca622f613ecdf.zip
removed a bunch of unused vim stuff
Diffstat (limited to '.vim/c-support/codesnippets/Makefile.multi-target.template')
-rw-r--r--.vim/c-support/codesnippets/Makefile.multi-target.template70
1 files changed, 0 insertions, 70 deletions
diff --git a/.vim/c-support/codesnippets/Makefile.multi-target.template b/.vim/c-support/codesnippets/Makefile.multi-target.template
deleted file mode 100644
index 75da8dd..0000000
--- a/.vim/c-support/codesnippets/Makefile.multi-target.template
+++ /dev/null
@@ -1,70 +0,0 @@
-#===============================================================================
-#
-# File: Makefile
-# Description:
-#
-# Usage: make (generate executable(s) )
-# make clean (remove objects, executables, prerequisits )
-# make tarball (generate compressed archive )
-# make zip (generate compressed archive )
-#
-# Author: Dr.-Ing. Fritz Mehner
-# Email: mehner@mfh-iserlohn.de
-# Created:
-#
-#===============================================================================
-
-
-CC = gcc
-CCP = g++
-CFLAGS = -c -g -Wall
-LFLAGS = -g
-SYS_LIBS = -lm
-TARBALL_EXCLUDE = "*.{o,gz,zip}"
-ZIP_EXCLUDE = *.o *.gz *.zip
-
-TARGETS = target_1 target_2
-
-#---------- targets --------------------------------------
-all: $(TARGETS)
-
-%.o: %.c
- $(CC) $(CFLAGS) $*.c
-
-%.o: %.cc
- $(CCP) $(CFLAGS) $*.cc
-
-#---------- target 1 -------------------------------------
-# C target
-target_1: target_1.o
- $(CC) $(LFLAGS) -o $@ $@.o $(SYS_LIBS)
-
-#---------- target 2 -------------------------------------
-# C++ target
-target_2: target_2.o
- $(CCP) $(LFLAGS) -o $@ $@.o $(SYS_LIBS)
-
-
-#---------- target 3 -------------------------------------
-
-
-
-#---------- tarball --------------------------------------
-tarball:
- lokaldir=`pwd`; lokaldir=$${lokaldir##*/}; \
- rm --force $$lokaldir.tar.gz; \
- tar --exclude=$(TARBALL_EXCLUDE) \
- --create \
- --gzip \
- --verbose \
- --file $$lokaldir.tar.gz *
-
-#---------- zip ------------------------------------------
-zip:
- lokaldir=`pwd`; lokaldir=$${lokaldir##*/}; \
- zip -r $$lokaldir.zip * -x $(ZIP_EXCLUDE)
-
-#---------- clear up -------------------------------------
-clean:
- rm --force $(EXECUTABLE) $(OBJECTS) $(PREREQUISITES)
-