aboutsummaryrefslogtreecommitdiffstats
path: root/modelica-parser-lalrpop/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'modelica-parser-lalrpop/Cargo.toml')
-rw-r--r--modelica-parser-lalrpop/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/modelica-parser-lalrpop/Cargo.toml b/modelica-parser-lalrpop/Cargo.toml
new file mode 100644
index 0000000..fabffe5
--- /dev/null
+++ b/modelica-parser-lalrpop/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "modelica-parser-lalrpop"
+version = "0.1.0"
+authors = ["bnewbold <bnewbold@robocracy.org>"]
+description = """
+Partial (work in progress) parser for the modelica language using the LALRPOP
+rust parser crate.
+"""
+keywords = ["modelica", "lalrpop", "parser"]
+build = "src/build.rs" # LALRPOP preprocessing
+license = "MIT"
+
+[lib]
+name = "modelica_parser"
+
+[dependencies]
+lalrpop-util = "^0.12.4"
+colored = "1.3"
+
+[build-dependencies]
+lalrpop = "0.12"
+
+[features]
+# this effectively enables the feature `no-color` of colored when testing
+test = ["colored/no-color"]