aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbnewbold <bnewbold@robocracy.org>2016-12-17 18:34:47 -0800
committerbnewbold <bnewbold@robocracy.org>2016-12-17 18:34:47 -0800
commit9f82aceb9fbdb42f332d68f4a423123bd0788b2c (patch)
treec082b9795be8e9e9d286c8f8f1345d22f3ec1b59 /Cargo.toml
parentf6364ebcac0d0a88a3cc6812fd2120c97b42cc26 (diff)
downloadmodelthing-9f82aceb9fbdb42f332d68f4a423123bd0788b2c.tar.gz
modelthing-9f82aceb9fbdb42f332d68f4a423123bd0788b2c.zip
refactor modelica parser into separate crate
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 57aa54b..cd16e93 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,19 +2,14 @@
name = "modelthing"
version = "0.1.0"
authors = ["bnewbold <bnewbold@robocracy.org>"]
-build = "src/build.rs" # eg, LALRPOP preprocessing
-
-[build-dependencies]
-lalrpop = "0.12"
[dependencies]
getopts = "^0.2"
toml = "0.2"
log = "0.3"
env_logger = "0.3"
-lalrpop-util = "^0.12.4"
markdown = "0.1"
-colored = "1.3"
+modelica-parser-lalrpop = { version = "*", path = "./modelica-parser-lalrpop" }
# parser util
rustc-serialize = "0.3"
@@ -23,7 +18,3 @@ docopt = "0.6"
# webface
pencil = "0.3"
-
-[features]
-# this effectively enables the feature `no-color` of colored when testing
-test = ["colored/no-color"]