aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Czygan <martin@archive.org>2021-10-28 17:10:18 +0000
committerMartin Czygan <martin@archive.org>2021-10-28 17:10:18 +0000
commit615439df4955ca19bf3fdfa10b41b7d8950b3e63 (patch)
tree07113024c75e673517c98055e9e5e61d7af97613 /setup.py
parent478d7d06ad9e56145cb94f3461c355b1ba9eb491 (diff)
parentb9f43f58be717ab56bb3c07691c422e88da997c9 (diff)
downloadfuzzycat-615439df4955ca19bf3fdfa10b41b7d8950b3e63.tar.gz
fuzzycat-615439df4955ca19bf3fdfa10b41b7d8950b3e63.zip
Merge branch 'bnewbold-tweaks' into 'master'
tweaks to deps and packaging; add files,contribs in live match release lookups See merge request webgroup/fuzzycat!8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 99519e7..040bbc6 100644
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,7 @@ with open("README.md", "r") as fh:
long_description_content_type="text/markdown",
url="https://github.com/miku/fuzzycat",
packages=setuptools.find_packages(),
+ package_data={"fuzzycat": ["py.typed"]},
classifiers=[
"Programming Language :: Python :: 3",
"License :: OSI Approved :: MIT License",
@@ -27,8 +28,9 @@ with open("README.md", "r") as fh:
]},
install_requires=[
"dynaconf>=3",
- "elasticsearch-dsl>=7.0.0,<8.0.0",
- "fatcat-openapi-client>=0.3.3", # https://pypi.org/project/fatcat-openapi-client/
+ "elasticsearch>=7.8.0,<7.14.0",
+ "elasticsearch-dsl>=7.0.0,<8.0.0",
+ "fatcat-openapi-client>=0.4.0", # https://pypi.org/project/fatcat-openapi-client/
"ftfy",
"glom",
"jellyfish",