aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Czygan <martin.czygan@gmail.com>2020-08-12 11:09:44 +0200
committerMartin Czygan <martin.czygan@gmail.com>2020-08-12 11:09:44 +0200
commit4001a5c053bb3bb2fec8761f6fc9331fbf2e2f83 (patch)
tree3971c36a3957c55ae04a12bbdae292cf9f5cc61b /setup.py
parenta9706afe0f54faead48fc641e8b6f90ed5e403a4 (diff)
downloadfuzzycat-4001a5c053bb3bb2fec8761f6fc9331fbf2e2f83.tar.gz
fuzzycat-4001a5c053bb3bb2fec8761f6fc9331fbf2e2f83.zip
basic scaffolding
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9e42793
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+import setuptools
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+ setuptools.setup(
+ name="fuzzycat",
+ version="0.1.0",
+ author="Martin Czygan",
+ author_email="martin@archive.org",
+ description="Fuzzy matching utilities for scholarly metadata",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://github.com/miku/fuzzycat",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+ python_requires=">=3.6",
+ zip_safe=False,
+ entry_points={"console_scripts": ["fuzzycat=fuzzycat.main:main",],},
+ install_requires=[],
+ extras_require={"dev": ["black>=19"],},
+ )