aboutsummaryrefslogtreecommitdiffstats
path: root/rust/fatcat-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/fatcat-api/Cargo.toml')
-rw-r--r--rust/fatcat-api/Cargo.toml27
1 files changed, 11 insertions, 16 deletions
diff --git a/rust/fatcat-api/Cargo.toml b/rust/fatcat-api/Cargo.toml
index 8eb4279d..3c226029 100644
--- a/rust/fatcat-api/Cargo.toml
+++ b/rust/fatcat-api/Cargo.toml
@@ -7,37 +7,32 @@ license = "Unlicense"
[features]
default = ["client", "server"]
-client = ["serde_json", "serde_ignored", "hyper", "hyper-tls", "native-tls", "openssl", "tokio-core", "url", "uuid"]
-server = ["serde_json", "serde_ignored", "hyper", "hyper-tls", "native-tls", "openssl", "tokio-core", "tokio-proto", "tokio-tls", "regex", "percent-encoding", "url", "uuid"]
+client = ["serde_json", "serde_ignored", "hyper", "hyper-openssl", "uuid"]
+server = ["serde_json", "serde_ignored", "hyper", "iron", "router", "bodyparser", "urlencoded", "uuid"]
[dependencies]
# Required by example server.
#
chrono = { version = "0.4", features = ["serde"] }
futures = "0.1"
-hyper = {version = "0.11", optional = true}
-hyper-tls = {version = "0.1.2", optional = true}
-swagger = "0.10.0"
+hyper = {version = "0.10", optional = true}
+hyper-openssl = {version = "0.2", optional = true }
+iron = {version = "0.5", optional = true}
+swagger = "0.7"
# Not required by example server.
#
+bodyparser = {version = "0.7", optional = true}
+url = "1.5"
lazy_static = "0.2"
log = "0.3.0"
-mime = "0.3.3"
-multipart = {version = "0.13.3", optional = true}
-native-tls = {version = "0.1.4", optional = true}
-openssl = {version = "0.9.14", optional = true}
-percent-encoding = {version = "1.0.0", optional = true}
-regex = {version = "0.2", optional = true}
+multipart = {version = "0.13", optional = true}
+router = {version = "0.5", optional = true}
serde = "1.0"
serde_derive = "1.0"
serde_ignored = {version = "0.0.4", optional = true}
serde_json = {version = "1.0", optional = true}
-serde_urlencoded = {version = "0.5.1", optional = true}
-tokio-core = {version = "0.1.6", optional = true}
-tokio-proto = {version = "0.1.1", optional = true}
-tokio-tls = {version = "0.1.3", optional = true, features = ["tokio-proto"]}
-url = {version = "1.5", optional = true}
+urlencoded = {version = "0.5", optional = true}
uuid = {version = "0.5", optional = true, features = ["serde", "v4"]}
# ToDo: this should be updated to point at the official crate once
# https://github.com/RReverser/serde-xml-rs/pull/45 is accepted upstream