aboutsummaryrefslogtreecommitdiffstats
path: root/rust/fatcat-api-spec/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2019-09-05 19:04:34 -0700
committerBryan Newbold <bnewbold@robocracy.org>2019-09-05 19:04:34 -0700
commitba722671b4791524384010705bef0aaa83c22c0b (patch)
tree9d546b87a36cfa521d8a64ea032948416c9e6314 /rust/fatcat-api-spec/Cargo.toml
parenta65dfc914517376b5ededb82e594236c5d61c721 (diff)
downloadfatcat-ba722671b4791524384010705bef0aaa83c22c0b.tar.gz
fatcat-ba722671b4791524384010705bef0aaa83c22c0b.zip
rename rust crate fatcat-api-spec -> fatcat-openapi
Diffstat (limited to 'rust/fatcat-api-spec/Cargo.toml')
-rw-r--r--rust/fatcat-api-spec/Cargo.toml43
1 files changed, 0 insertions, 43 deletions
diff --git a/rust/fatcat-api-spec/Cargo.toml b/rust/fatcat-api-spec/Cargo.toml
deleted file mode 100644
index 9d416bd9..00000000
--- a/rust/fatcat-api-spec/Cargo.toml
+++ /dev/null
@@ -1,43 +0,0 @@
-[package]
-name = "fatcat-api-spec"
-version = "0.3.0"
-authors = ["Bryan Newbold <bnewbold@archive.org>"]
-description = "HTTP API models, endpoints, and other auto-generated types"
-license = "CC-0"
-
-[features]
-default = ["client", "server"]
-client = ["serde_json", "serde_ignored", "hyper", "hyper-openssl", "uuid"]
-server = ["serde_json", "serde_ignored", "hyper", "iron", "router", "bodyparser", "urlencoded", "uuid"]
-
-[dependencies]
-# Required by example server.
-#
-chrono = { version = "0.4", features = ["serde"] }
-futures = "0.1"
-hyper = {version = "0.10", optional = true}
-hyper-openssl = {version = "0.2", optional = true }
-iron = {version = "0.6", optional = true}
-swagger = "0.7"
-
-# Not required by example server.
-#
-bodyparser = {version = "0.8", optional = true}
-url = "1.5"
-lazy_static = "0.2"
-log = "0.3.0"
-multipart = {version = "0.13", optional = true}
-router = {version = "0.6", optional = true}
-serde = "1.0"
-serde_derive = "1.0"
-serde_ignored = {version = "0.0.4", optional = true}
-serde_json = {version = "1.0", optional = true}
-urlencoded = {version = "0.6", optional = true}
-uuid = {version = "0.5", optional = true, features = ["serde", "v4"]}
-# ToDo: this should be updated to point at the official crate once
-# https://github.com/RReverser/serde-xml-rs/pull/45 is accepted upstream
-
-
-[dev-dependencies]
-clap = "2.25"
-error-chain = "0.11"