aboutsummaryrefslogtreecommitdiffstats
path: root/fatcat-cli/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2021-02-09 18:57:00 -0800
committerBryan Newbold <bnewbold@archive.org>2021-02-09 18:57:00 -0800
commit19c582a3cf1c42e9c75170650ccd141eda903479 (patch)
tree0738781689e4c12308016f184cb6eb02af1716a6 /fatcat-cli/Cargo.toml
parentbab3fb9fdcc921e1bb8a81e0f2b4e12558d2dde7 (diff)
downloadfatcat-cli-19c582a3cf1c42e9c75170650ccd141eda903479.tar.gz
fatcat-cli-19c582a3cf1c42e9c75170650ccd141eda903479.zip
move source code to top-level directory
Diffstat (limited to 'fatcat-cli/Cargo.toml')
-rw-r--r--fatcat-cli/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/fatcat-cli/Cargo.toml b/fatcat-cli/Cargo.toml
new file mode 100644
index 0000000..dbb114a
--- /dev/null
+++ b/fatcat-cli/Cargo.toml
@@ -0,0 +1,55 @@
+[package]
+name = "fatcat-cli"
+version = "0.3.0-dev"
+edition = "2018"
+authors = ["Bryan Newbold <bnewbold@robocracy.org>"]
+license = "AGPL-3+"
+#license-file = "../../LICENSE.AGPLv3.txt"
+description = "CLI tool for fatcat.wiki, an open digital catalog of research papers"
+readme = "fatcat-cli/README.md"
+homepage = "https://fatcat.wiki"
+repository = "https://github.com/internetarchive/fatcat"
+keywords = ["cli", "fatcat", "digital-library"]
+categories = ["command-line-utilities"]
+
+
+[dependencies]
+data-encoding = "2.1"
+fatcat-openapi = { version = "*", path = "../fatcat-openapi", default-features = false, features = ["client"] }
+macaroon = { git = "https://github.com/bnewbold/libmacaroon-rs", branch = "bnewbold-broken" }
+toml = "0.5"
+termcolor = "1"
+atty = "0.2"
+tabwriter = "1.2"
+#human-panic = "1"
+structopt = "0.3"
+swagger = "5.0.2"
+hyper = "0.13"
+tokio = { version = "0.2", features = ["rt-threaded", "macros", "stream"] }
+serde_json = "1.0"
+anyhow = "1.0"
+log = "0.4"
+env_logger = "0.7"
+regex = { version = "1.3", default-features = false, features = ["perf-literal"] }
+lazy_static = "1"
+serde = "1.0"
+reqwest = { version = "0.10", features = ["blocking", "json"] }
+chrono-humanize = "*"
+tempfile = "3"
+indicatif = "0.15"
+url = "*"
+
+
+[dev-dependencies]
+assert_cmd = "1"
+
+
+[package.metadata.deb]
+maintainer = "Bryan Newbold <bnewbold@robocracy.org>"
+depends = "$auto"
+section = "utility"
+priority = "optional"
+assets = [
+ ["target/release/fatcat-cli", "usr/bin/", "755"],
+ ["fatcat-cli.1", "usr/share/man/man1/", "644"],
+]