aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2020-08-25 18:42:26 -0700
committerBryan Newbold <bnewbold@archive.org>2020-08-25 18:42:26 -0700
commit2f9054309e3d12be5b9d9be56c09e935c0bc0c06 (patch)
treed853cb17a07fe97129422b20dec5f70164699b89 /Cargo.toml
parent2ab089684a1bdbbb6f1f027399adb61d5e8f7291 (diff)
downloades-public-proxy-2f9054309e3d12be5b9d9be56c09e935c0bc0c06.tar.gz
es-public-proxy-2f9054309e3d12be5b9d9be56c09e935c0bc0c06.zip
reduce tokio feature flags
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 1 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 16bdb08..d0d860e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,17 +4,11 @@ version = "0.1.0"
authors = ["Bryan Newbold <bnewbold@archive.org>"]
edition = "2018"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[dependencies]
hyper = "0.13"
http = "*"
-tokio = { version = "0.2", features = ["full"] }
+tokio = { version = "0.2", features = ["rt-threaded", "tcp", "signal", "macros"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.5"
toml = "0.4"
-
-# testing
-#anyhow = "1"
-#reqwest = { version = "0.10", features = ["blocking"] }