aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog248
1 files changed, 248 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 31bec12..15aaad9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,251 @@
+2006-10-21 Aubrey Jaffer <jaffer@aubrey.jaffer>
+
+ * require.scm (*slib-version*): Bumped from 3a3 to 3a4.
+
+2006-10-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * grapheps.scm (plot): Handle list of lists data.
+
+2006-10-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * slib.texi (Sorting): Updated; cleaned up.
+
+ * sort.scm (merge!): Fixed.
+ (sort!): Swap pairs so that list returned EQ? to argument.
+
+2006-10-11 Aubrey Jaffer <ajaffer@clearmethods.com>
+
+ * slib.texi (Sorting): Added optional KEY arguments.
+
+ * sort.scm (sort, sort!, sorted?, merge, merge!): Added optional
+ KEY argument.
+
+2006-09-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * dft.scm (dft, dft-1): Added routines which use the best method
+ for decimating each dimension.
+ (dft:dft): Call 1d transform only with contiguous arrays.
+ (dft:dft): Tested and fixed for ranks 1 to 3.
+
+2006-09-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * dft.scm (dft:check-dimensions): Abstracted from fft and fft-1.
+
+2006-09-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * tzfile.scm (tzfile:read): Use subbytes instead of subarray.
+
+ * byte.scm (subbytes): Added.
+ (subbytes-read!, subbytes-write): Renamed from substring-...
+
+2006-09-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (txiscms): Aded math-integer.
+ (afiles): Added math-real.
+
+ * slib.texi (Irrational Real Functions)
+ (Irrational Integer Functions): Sections added.
+
+ * math-integer.scm, math-real.scm: Added.
+
+2006-09-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * slib.texi (Feature): Indexed number-system attribute features.
+
+ * require.scm: Tightened number-system attribute features.
+
+2006-09-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * indexes.texi (Index): Removed "Full Table of Contents".
+
+ * slib.texi (SRFI): Added @ftindex entries.
+
+2006-09-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * slib.texi (SRFI): Added @ftindex entries for SRFIs.
+
+ * vscm.init, umbscheme.init, Template.scm, t3.init, STk.init,
+ scsh.init, scheme2c.init, RScheme.init, mitscheme.init,
+ macscheme.init, jscheme.init, gambit.init, elk.init,
+ DrScheme.init, chez.init, bigloo.init (slib:error): Capture
+ `error' identifier (to survive redefinition).
+
+ * srfi-23.scm (error): File added.
+
+ * elk.init (slib:error): Removed bad insertion.
+
+2006-09-12 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * peanosfc.scm (peano-coordinates->integer)
+ (integer->peano-coordinates): Fixed; were broken for rank != 2.
+
+2006-09-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * root.scm (integer-sqrt): Streamlined.
+
+2006-09-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * dft.scm (sft, sft-1, fft, fft-1): Added optional array-prototype
+ argument.
+
+ * subarray.scm (subarray): Handle reverse index ranges.
+
+2006-09-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * pnm.scm (pnm:array-write): Don't lose comments when recursing.
+
+ * dft.scm (sft, sft-1): Slow Fourier transforms added.
+ (dft:sft1d!, dft:fft1d!): Flipped polarity of exponent to agree
+ with http://en.wikipedia.org/wiki/Discrete_Fourier_transform.
+
+ * dft.scm: Renamed from "fft.scm".
+
+2006-09-03 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * fft.scm (fft:dft): Generalized to any positive rank.
+
+2006-09-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * slib.spec (%files): Added man1/slib.1.gz.
+
+2006-08-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * grapheps.ps (sign): Cleaner than inline code.
+
+2006-08-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (dvi, pdf): New tetex-3.0(-20.FC5) broke them -- fixed.
+
+2006-08-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * grapheps.ps (setup-plot): Now handles decreasing axes.
+
+2006-07-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * grapheps.scm (rule-horizontal): Corrected documentation.
+
+2006-07-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * root.scm (secant:find-root-1): Fixed internal argument mismatch
+ for number-of-iterations case.
+
+2006-06-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * bigloo.init (slib:features): Lacks object-hash.
+
+2006-06-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * getopt.scm (*argv*): Removed (define *argv* *argv*).
+
+2006-05-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * solid.scm (solid:prism, solid:lumber): Added.
+
+2006-05-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * array.scm (make-shared-array): Work for rank-0 arrays.
+ (equal?): Compare element-by-element of two arrays.
+ (make-array): Return string or vector even if prototype is a
+ strict array.
+
+2006-05-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * array.scm (make-array): Return simple string or vector if
+ possible.
+
+2006-05-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * slib.texi: Converted to @copying and GNU Free Documentation
+ License.
+
+ * Makefile (docs): Added target to make all documentation files
+ and invoke xdvi.
+ (texifiles): Added fdl.texi.
+
+2006-05-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * bigloo.init (slib:load): Fixed suffix lossage.
+ (slib:features): Removed object->string and rationalize.
+
+ * strcase.scm (symbol-append): Work with case-sensitive or
+ case-insensitive symbols.
+
+2006-05-01 Ivan Shmakov
+
+ * scheme48.init (file-exists?): Much simplified.
+
+2006-04-23 Kevin Ryde
+
+ * guile.init: Fixed line-i/o in Guile >= 1.8.
+
+ * srfi-1.scm (reduce-right): Was infinite loop.
+
+2006-04-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * *.init, Template.scm, require.scm (slib:features): Renamed from
+ *features* to avoid conflict with Guile identifier.
+
+2006-04-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (S48LIB): Renamed from LIB.
+ (S48SLIB): Subdirectory of implementation-vicinity.
+ (install48): Make $(S48SLIB) directory and files.
+
+2006-04-05 Ben Goetter
+
+ * pscheme.init: Revised for Pscheme 1.3.
+
+2006-04-03 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * simetrix.scm (SI:unit-infos): Updated u and eV to CODATA-2002.
+
+2006-03-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * require.scm (catalog:get): Handle (home-vicinity) being false.
+
+2006-03-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scheme48.init: (slib:load-compiled): Loads a native SRFI module.
+ Create "implcat" and new-catalog with native SRFI modules.
+
+2006-03-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * modular.scm (modular:characteristic, modular:+): Recoded so `-'
+ has no more than 2 arguments.
+
+2006-03-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scheme48.init (slib-primitives): Removed s48-modulo and
+ s48-atan.
+
+ * guile.init (char-code-limit): Reduced to workaround string
+ ordering bug.
+
+2006-03-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * guile.init (system, delete-file, open-file, make-array): Changed
+ from define to set! to eliminate guile-1.8.0 warning:
+ WARNING: (guile-user): imported module (ice-9 slib) overrides core binding
+
+2006-03-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * guile.init (defined?, in-vicinity, port?, 1+, -1+, 1-): Removed
+ definitions duplicating Guile defines.
+ (*features*): Set, rather than define.
+ (browse-url): Added.
+
+ * require.scm (catalog:get): mklibcat is `source'.
+ (require): Don't provide `new-catalog'.
+
+ * mklibcat.scm: Change all slib files to `source'.
+
+2006-03-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * modular.scm (mod, rem): Removed.
+ (modular:characteristic): Renamed from modulus->integer.
+ (modular:expt): Handle base = modulus - 1.
+ Corrected documentation.
+
2006-02-13 Aubrey Jaffer <jaffer@aubrey>
* require.scm (*slib-version*): Bumped from 3a2 to 3a3.