summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Config.in19
-rw-r--r--toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-001-libext.patch13
-rw-r--r--toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-002-rm-whitespace.patch77
-rw-r--r--toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.3/.empty0
-rw-r--r--toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.5/.empty0
-rw-r--r--toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/.empty0
-rw-r--r--toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch (renamed from toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch)0
-rw-r--r--toolchain/uClibc/uclibc.mk28
8 files changed, 24 insertions, 113 deletions
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index d0486abd6..cc7dcd1a9 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -5,35 +5,40 @@ comment "uClibc Options"
choice
prompt "uClibc C library Version"
- default BR2_UCLIBC_VERSION_0_9_30_1
+ default BR2_UCLIBC_VERSION_0_9_30_1 if !BR2_avr32
+ default BR2_UCLIBC_VERSION_0_9_30_AVR32_2_1_5 if BR2_avr32
help
Select the version of uClibc you wish to use.
config BR2_UCLIBC_VERSION_0_9_28_3
+ depends on !BR2_avr32
depends on BR2_DEPRECATED
bool "uClibc 0.9.28.3"
- depends on BR2_EXT_UCLIBC_VERSION_0_9_28_3
config BR2_UCLIBC_VERSION_0_9_29
+ depends on !BR2_avr32
depends on BR2_DEPRECATED
bool "uClibc 0.9.29"
- depends on BR2_EXT_UCLIBC_VERSION_0_9_29
config BR2_UCLIBC_VERSION_0_9_30
+ depends on !BR2_avr32
depends on BR2_RECENT || BR2_DEPRECATED
bool "uClibc 0.9.30"
- depends on BR2_EXT_UCLIBC_VERSION_0_9_30
+
+ config BR2_UCLIBC_VERSION_0_9_30_AVR32_2_1_5
+ depends on BR2_avr32
+ bool "uClibc 0.9.30-avr32-2.1.5"
config BR2_UCLIBC_VERSION_0_9_30_1
+ depends on !BR2_avr32
bool "uClibc 0.9.30.1"
- depends on BR2_EXT_UCLIBC_VERSION_0_9_30_1
config BR2_UCLIBC_VERSION_SNAPSHOT
+ depends on !BR2_avr32
bool "daily snapshot"
endchoice
-
config BR2_USE_UCLIBC_SNAPSHOT
string "Date (yyyymmdd) of snapshot or 'snapshot' for latest"
default "snapshot"
@@ -47,6 +52,7 @@ config BR2_UCLIBC_VERSION_STRING
default 0.9.29 if BR2_UCLIBC_VERSION_0_9_29
default 0.9.30 if BR2_UCLIBC_VERSION_0_9_30
default 0.9.30.1 if BR2_UCLIBC_VERSION_0_9_30_1
+ default 0.9.30-avr32-2.1.5 if BR2_UCLIBC_VERSION_0_9_30_AVR32_2_1_5
default $BR2_USE_UCLIBC_SNAPSHOT if BR2_UCLIBC_VERSION_SNAPSHOT
config BR2_UCLIBC_CONFIG
@@ -55,6 +61,7 @@ config BR2_UCLIBC_CONFIG
default "toolchain/uClibc/uClibc-0.9.29.config" if BR2_UCLIBC_VERSION_0_9_29
default "toolchain/uClibc/uClibc-0.9.30.config" if BR2_UCLIBC_VERSION_0_9_30
default "toolchain/uClibc/uClibc-0.9.30.config" if BR2_UCLIBC_VERSION_0_9_30_1
+ default "toolchain/uClibc/uClibc-0.9.30.config" if BR2_UCLIBC_VERSION_0_9_30_AVR32_2_1_5
default "toolchain/uClibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_SNAPSHOT
help
Some people may wish to use their own modified uClibc configuration
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-001-libext.patch b/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-001-libext.patch
deleted file mode 100644
index e1740a7ac..000000000
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-001-libext.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urN uClibc-0.9.28.3-0rig/Makefile uClibc-0.9.28.3/Makefile
---- uClibc-0.9.28.3-0rig/Makefile 2007-07-29 08:20:33.000000000 +0200
-+++ uClibc-0.9.28.3/Makefile 2007-08-20 07:02:53.000000000 +0200
-@@ -157,7 +157,8 @@
- install_dev:
- $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
- $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
-- -$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
-+ -$(INSTALL) -m 644 lib/*.a $(PREFIX)$(DEVEL_PREFIX)lib/
-+ -$(INSTALL) -m 644 lib/*.so* $(PREFIX)$(DEVEL_PREFIX)lib/
- if [ "$(KERNEL_SOURCE)" = "$(DEVEL_PREFIX)" ] ; then \
- extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
- else \
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-002-rm-whitespace.patch b/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-002-rm-whitespace.patch
deleted file mode 100644
index 2ae026588..000000000
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.28.3-avr32-2.0/uClibc-0.9.28.3-avr32-2.0-002-rm-whitespace.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff -urN uClibc-0.9.29-0rig/include/assert.h uClibc-0.9.29/include/assert.h
---- uClibc-0.9.29-0rig/include/assert.h 2005-11-03 23:42:46.000000000 +0100
-+++ uClibc-0.9.29/include/assert.h 2007-08-13 19:10:57.000000000 +0200
-@@ -31,7 +31,7 @@
- #define _ASSERT_H 1
- #include <features.h>
-
--#if defined __cplusplus && __GNUC_PREREQ (2,95)
-+#if defined __cplusplus && __GNUC_PREREQ(2,95)
- # define __ASSERT_VOID_CAST static_cast<void>
- #else
- # define __ASSERT_VOID_CAST (void)
-@@ -59,13 +59,17 @@
- (__ASSERT_VOID_CAST ((expr) ? 0 : \
- (__assert (__STRING(expr), __FILE__, __LINE__, \
- __ASSERT_FUNCTION), 0)))
--
-+
-+/* Define some temporaries to workaround tinyx makedepend bug */
-+#define __GNUC_PREREQ_2_6 __GNUC_PREREQ(2, 6)
-+#define __GNUC_PREREQ_2_4 __GNUC_PREREQ(2, 4)
- /* Version 2.4 and later of GCC define a magical variable `__PRETTY_FUNCTION__'
- which contains the name of the function currently being defined.
- This is broken in G++ before version 2.6.
- C9x has a similar variable called __func__, but prefer the GCC one since
- it demangles C++ function names. */
--# if defined __cplusplus ? __GNUC_PREREQ (2, 6) : __GNUC_PREREQ (2, 4)
-+
-+# if defined __cplusplus ? __GNUC_PREREQ_2_6 : __GNUC_PREREQ_2_4
- # define __ASSERT_FUNCTION __PRETTY_FUNCTION__
- # else
- # if defined __STDC_VERSION__ && __STDC_VERSION__ >= 199901L
-diff -urN uClibc-0.9.29-0rig/include/complex.h uClibc-0.9.29/include/complex.h
---- uClibc-0.9.29-0rig/include/complex.h 2002-05-09 10:15:21.000000000 +0200
-+++ uClibc-0.9.29/include/complex.h 2007-08-13 17:55:29.000000000 +0200
-@@ -33,7 +33,7 @@
- /* We might need to add support for more compilers here. But since ISO
- C99 is out hopefully all maintained compilers will soon provide the data
- types `float complex' and `double complex'. */
--#if __GNUC_PREREQ (2, 7) && !__GNUC_PREREQ (2, 97)
-+#if __GNUC_PREREQ(2, 7) && !__GNUC_PREREQ(2, 97)
- # define _Complex __complex__
- #endif
-
-diff -urN uClibc-0.9.29-0rig/include/features.h uClibc-0.9.29/include/features.h
---- uClibc-0.9.29-0rig/include/features.h 2006-11-29 22:10:04.000000000 +0100
-+++ uClibc-0.9.29/include/features.h 2007-08-13 17:55:51.000000000 +0200
-@@ -143,7 +143,7 @@
-
- /* Convenience macros to test the versions of glibc and gcc.
- Use them like this:
-- #if __GNUC_PREREQ (2,8)
-+ #if __GNUC_PREREQ(2,8)
- ... code requiring gcc 2.8 or later ...
- #endif
- Note - they won't work for gcc1 or glibc1, since the _MINOR macros
-@@ -366,7 +366,7 @@
- #endif /* !ASSEMBLER */
-
- /* Decide whether we can define 'extern inline' functions in headers. */
--#if __GNUC_PREREQ (2, 7) && defined __OPTIMIZE__ \
-+#if __GNUC_PREREQ(2, 7) && defined __OPTIMIZE__ \
- && !defined __OPTIMIZE_SIZE__ && !defined __NO_INLINE__
- # define __USE_EXTERN_INLINES 1
- #endif
-diff -urN uClibc-0.9.29-0rig/include/tgmath.h uClibc-0.9.29/include/tgmath.h
---- uClibc-0.9.29-0rig/include/tgmath.h 2002-05-09 10:15:21.000000000 +0200
-+++ uClibc-0.9.29/include/tgmath.h 2007-08-13 17:56:17.000000000 +0200
-@@ -34,7 +34,7 @@
- do not try this for now and instead concentrate only on GNU CC. Once
- we have more information support for other compilers might follow. */
-
--#if __GNUC_PREREQ (2, 7)
-+#if __GNUC_PREREQ(2, 7)
-
- # ifdef __NO_LONG_DOUBLE_MATH
- # define __tgml(fct) fct
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.3/.empty b/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.3/.empty
deleted file mode 100644
index e69de29bb..000000000
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.3/.empty
+++ /dev/null
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.5/.empty b/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.5/.empty
deleted file mode 100644
index e69de29bb..000000000
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.29-avr32-2.1.5/.empty
+++ /dev/null
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/.empty b/toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/.empty
deleted file mode 100644
index e69de29bb..000000000
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/.empty
+++ /dev/null
diff --git a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch b/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
index eb8888470..eb8888470 100644
--- a/toolchain/uClibc/ext_source/Atmel/avr32/0.9.30-avr32-2.1.5/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
+++ b/toolchain/uClibc/uClibc-0.9.30-avr32-2.1.5-unifdef-getline.patch
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 62fc40b26..f742d4ef4 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -4,7 +4,7 @@
#
#############################################################
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
# specifying UCLIBC_CONFIG_FILE on the command-line overrides the .config
# setting.
@@ -12,28 +12,19 @@ ifndef UCLIBC_CONFIG_FILE
UCLIBC_CONFIG_FILE=$(call qstrip,$(BR2_UCLIBC_CONFIG))
endif
-UCLIBC_VER:=$(call qstrip,$(BR2_UCLIBC_VERSION_STRING))
-
-UCLIBC_OFFICIAL_VERSION:=$(UCLIBC_VER)$(VENDOR_SUFFIX)$(VENDOR_UCLIBC_RELEASE)
+UCLIBC_VERSION:=$(call qstrip,$(BR2_UCLIBC_VERSION_STRING))
ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
-UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc
+else ifeq ($(findstring avr32,$(UCLIBC_VERSION)),avr32)
+UCLIBC_SITE:=ftp://www.at91.com/pub/buildroot/
else
-UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc-$(UCLIBC_OFFICIAL_VERSION)
UCLIBC_SITE:=http://www.uclibc.org/downloads
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SOURCE),y)
-UCLIBC_SITE:=$(VENDOR_SITE)
-endif
endif
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc-$(UCLIBC_VERSION)
UCLIBC_PATCH_DIR:=toolchain/uClibc/
-else
-UCLIBC_PATCH_DIR:=toolchain/uClibc/ext_source/$(VENDOR_PATCH_DIR)/$(UCLIBC_OFFICIAL_VERSION)
-endif
-
-UCLIBC_SOURCE:=uClibc-$(UCLIBC_OFFICIAL_VERSION).tar.bz2
+UCLIBC_SOURCE:=uClibc-$(UCLIBC_VERSION).tar.bz2
UCLIBC_CAT:=$(BZCAT)
@@ -103,8 +94,8 @@ uclibc-patched: $(UCLIBC_DIR)/.patched
$(UCLIBC_DIR)/.patched: $(UCLIBC_DIR)/.unpacked
ifneq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
toolchain/patch-kernel.sh $(UCLIBC_DIR) $(UCLIBC_PATCH_DIR) \
- uClibc-$(UCLIBC_OFFICIAL_VERSION)-\*.patch \
- uClibc-$(UCLIBC_OFFICIAL_VERSION)-\*.patch.$(ARCH)
+ uClibc-$(UCLIBC_VERSION)-\*.patch \
+ uClibc-$(UCLIBC_VERSION)-\*.patch.$(ARCH)
else
toolchain/patch-kernel.sh $(UCLIBC_DIR) $(UCLIBC_PATCH_DIR) \
uClibc.\*.patch uClibc.\*.patch.$(ARCH)
@@ -257,6 +248,9 @@ else
/bin/echo "# CONFIG_E500 is not set" >> $(UCLIBC_DIR)/.oldconfig
endif
endif
+ifeq ($(UCLIBC_TARGET_ARCH),avr32)
+ /bin/echo "LINKRELAX=y" >> $(UCLIBC_DIR)/.oldconfig
+endif
ifneq ($(UCLIBC_TARGET_ENDIAN),)
# The above doesn't work for me, so redo
$(SED) 's/.*\(ARCH_$(UCLIBC_NOT_TARGET_ENDIAN)_ENDIAN\).*/# \1 is not set/g' \