summaryrefslogtreecommitdiffstats
path: root/target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain')
-rw-r--r--target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain b/target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain
new file mode 100644
index 000000000..53e509d3a
--- /dev/null
+++ b/target/device/jp/q5/kernel-patches-2.4.29/004-correct_toolchain
@@ -0,0 +1,24 @@
+--- linux-2.4.29/arch/mips/Makefile.orig 2005-03-08 23:24:05.000000000 -0700
++++ linux-2.4.29/arch/mips/Makefile 2005-03-08 23:27:37.000000000 -0700
+@@ -17,16 +17,16 @@
+ # Select the object file format to substitute into the linker script.
+ #
+ ifdef CONFIG_CPU_LITTLE_ENDIAN
+-tool-prefix = mipsel-linux-
++#tool-prefix = mipsel-linux-
+ ld-emul = elf32ltsmip
+ else
+-tool-prefix = mips-linux-
++#tool-prefix = mips-linux-
+ ld-emul = elf32btsmip
+ endif
+
+-ifdef CONFIG_CROSSCOMPILE
+-CROSS_COMPILE = $(tool-prefix)
+-endif
++#ifdef CONFIG_CROSSCOMPILE
++#CROSS_COMPILE = $(tool-prefix)
++#endif
+
+ MAKEBOOT = $(MAKE) -C arch/$(ARCH)/boot
+