summaryrefslogtreecommitdiffstats
path: root/package/vsftpd
diff options
context:
space:
mode:
Diffstat (limited to 'package/vsftpd')
-rw-r--r--package/vsftpd/vsftpd.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/vsftpd/vsftpd.mk b/package/vsftpd/vsftpd.mk
index c8c68d27b..64a56ccf2 100644
--- a/package/vsftpd/vsftpd.mk
+++ b/package/vsftpd/vsftpd.mk
@@ -19,6 +19,11 @@ VSFTPD_LIBS += -lssl
VSFTPD_POST_CONFIGURE_HOOKS += VSFTPD_ENABLE_SSL
endif
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+VSFTPD_DEPENDENCIES += libcap
+VSFTPD_LIBS += -lcap
+endif
+
define VSFTPD_BUILD_CMDS
$(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" LIBS="$(VSFTPD_LIBS)" -C $(@D)