summaryrefslogtreecommitdiffstats
path: root/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/uboot-tools/uboot-tools-drop-configh-from-tools.patch')
-rw-r--r--package/uboot-tools/uboot-tools-drop-configh-from-tools.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
new file mode 100644
index 000000000..21995ecf0
--- /dev/null
+++ b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
@@ -0,0 +1,37 @@
+We need to build u-boot tools without a board configuration for the target.
+fw_env just uses config.h to define the default environment of the created
+image, so it really isn't mandatory.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura u-boot-2013.01.orig/tools/env/fw_env.h u-boot-2013.01/tools/env/fw_env.h
+--- u-boot-2013.01.orig/tools/env/fw_env.h 2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/fw_env.h 2013-01-19 07:58:11.897903403 -0300
+@@ -21,15 +21,6 @@
+ * MA 02111-1307 USA
+ */
+
+-/* Pull in the current config to define the default environment */
+-#ifndef __ASSEMBLY__
+-#define __ASSEMBLY__ /* get only #defines from config.h */
+-#include <config.h>
+-#undef __ASSEMBLY__
+-#else
+-#include <config.h>
+-#endif
+-
+ /*
+ * To build the utility with the static configuration
+ * comment out the next line.
+diff -Nura u-boot-2013.01.orig/tools/env/Makefile u-boot-2013.01/tools/env/Makefile
+--- u-boot-2013.01.orig/tools/env/Makefile 2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/Makefile 2013-01-19 07:59:34.926486346 -0300
+@@ -26,7 +26,7 @@
+ HOSTSRCS := $(SRCTREE)/lib/crc32.c fw_env.c fw_env_main.c
+ HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
+ HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
+-HEADERS := fw_env.h $(OBJTREE)/include/config.h
++HEADERS := fw_env.h
+
+ # Compile for a hosted environment on the target
+ HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \