summaryrefslogtreecommitdiffstats
path: root/package/ramsmp/ramsmp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ramsmp/ramsmp.mk')
-rw-r--r--package/ramsmp/ramsmp.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/ramsmp/ramsmp.mk b/package/ramsmp/ramsmp.mk
new file mode 100644
index 000000000..1b4440237
--- /dev/null
+++ b/package/ramsmp/ramsmp.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# ramsmp
+#
+#############################################################
+
+RAMSMP_VERSION = 3.5.0
+RAMSMP_SITE = http://www.alasir.com/software/ramspeed
+RAMSMP_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
+
+define RAMSMP_BUILD_CMDS
+ cp -f package/ramsmp/Makefile $(@D)
+ $(TARGET_CONFIGURE_OPTS) make -C $(@D) $(RAMSMP_ARCH)
+endef
+
+define RAMSMP_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/ramsmp $(TARGET_DIR)/usr/bin/ramsmp
+endef
+
+$(eval $(generic-package))