summaryrefslogtreecommitdiffstats
path: root/package/python-bottle
diff options
context:
space:
mode:
Diffstat (limited to 'package/python-bottle')
-rw-r--r--package/python-bottle/Config.in8
-rw-r--r--package/python-bottle/python-bottle.mk22
2 files changed, 30 insertions, 0 deletions
diff --git a/package/python-bottle/Config.in b/package/python-bottle/Config.in
new file mode 100644
index 000000000..f9b60ca72
--- /dev/null
+++ b/package/python-bottle/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_BOTTLE
+ bool "python-bottle"
+ help
+ Bottle is a fast, simple and lightweight WSGI micro web-framework
+ for Python. It is distributed as a single file module and has no
+ dependencies other than the Python Standard Library.
+
+ http://bottlepy.org
diff --git a/package/python-bottle/python-bottle.mk b/package/python-bottle/python-bottle.mk
new file mode 100644
index 000000000..370b31be0
--- /dev/null
+++ b/package/python-bottle/python-bottle.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# python-bottle
+#
+#############################################################
+
+PYTHON_BOTTLE_VERSION = 0.11.4
+PYTHON_BOTTLE_SOURCE = bottle-$(PYTHON_BOTTLE_VERSION).tar.gz
+PYTHON_BOTTLE_SITE = http://pypi.python.org/packages/source/b/bottle
+PYTHON_BOTTLE_DEPENDENCIES = python
+PYTHON_BOTTLE_LICENSE = MIT
+# README.rst refers to the file "LICENSE" but it's not included
+
+define PYTHON_BOTTLE_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_BOTTLE_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(generic-package))