summaryrefslogtreecommitdiffstats
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 78c1ad35e..e92e134b6 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -11,17 +11,17 @@ NEON_CONF_OPT:=--enable-shared --without-gssapi --disable-rpath
NEON_DEPENDENCIES:=pkgconfig
-ifeq ($(strip $(BR2_PACKAGE_NEON_LIBXML2)),y)
+ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
NEON_CONF_OPT+=--with-libxml2=yes
NEON_CONF_OPT+=--with-expat=no
NEON_DEPENDENCIES+=libxml2
endif
-ifeq ($(strip $(BR2_PACKAGE_NEON_EXPAT)),y)
+ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no
NEON_DEPENDENCIES+=expat
endif
-ifeq ($(strip $(BR2_PACKAGE_NEON_NOXML)),y)
+ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
# webdav needs xml support
NEON_CONF_OPT+=--disable-webdav
endif