summaryrefslogtreecommitdiffstats
path: root/package/msmtp/msmtp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/msmtp/msmtp.mk')
-rw-r--r--package/msmtp/msmtp.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
index 2c712293d..d5e6a3123 100644
--- a/package/msmtp/msmtp.mk
+++ b/package/msmtp/msmtp.mk
@@ -13,6 +13,10 @@ MSMTP_DEPENDENCIES += host-pkg-config
ifeq ($(BR2_PACKAGE_OPENSSL),y)
MSMTP_CONF_OPT += --with-ssl=openssl
MSMTP_DEPENDENCIES += openssl
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+# openssl uses zlib, so we need to explicitly link with it when static
+MSMTP_CONF_ENV += LIBS=-lz
+endif
else ifeq ($(BR2_PACKAGE_GNUTLS),y)
MSMTP_CONF_OPT += --with-ssl=gnutls
MSMTP_DEPENDENCIES += gnutls