summaryrefslogtreecommitdiffstats
path: root/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch')
-rw-r--r--package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch51
1 files changed, 26 insertions, 25 deletions
diff --git a/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
index 3a1807ed5..fcaaa3e32 100644
--- a/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
+++ b/package/lttng-tools/lttng-tools-no-sync-file-range-in-uclibc.patch
@@ -16,35 +16,36 @@ diff --git a/configure.ac b/configure.ac
index 5808c79..065b9cf 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -120,7 +120,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
-
- AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [ test "x$ac_cv_lib_lttng_ust_ctl_ustctl_create_session" = "xyes" ])
-
+@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
+ )
+ ])
+ AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [test "x$lttng_ust_ctl_found" = xyes])
-AC_CHECK_FUNCS([sched_getcpu sysconf])
+AC_CHECK_FUNCS([sched_getcpu sysconf sync_file_range])
-
+
# check for dlopen
AC_CHECK_LIB([dl], [dlopen],
-diff --git a/src/common/compat/fcntl.h b/src/common/compat/fcntl.h
-index 58c1579..dafb33e 100644
---- a/src/common/compat/fcntl.h
-+++ b/src/common/compat/fcntl.h
-@@ -23,10 +23,15 @@
-
- #ifdef __linux__
-
-+#if defined(HAVE_SYNC_FILE_RANGE)
- extern int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
- unsigned int flags);
- #define lttng_sync_file_range(fd, offset, nbytes, flags) \
- compat_sync_file_range(fd, offset, nbytes, flags)
+@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],[
+ ])
+
+ AS_ECHO()
+-
+diff --git a/src/common/compat/compat-fcntl.c b/src/common/compat/compat-fcntl.c
+index 5a1c757..7ff63a3 100644
+--- a/src/common/compat/compat-fcntl.c
++++ b/src/common/compat/compat-fcntl.c
+@@ -23,7 +23,11 @@
+ int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
+ unsigned int flags)
+ {
++#ifdef HAVE_SYNC_FILE_RANGE
+ return sync_file_range(fd, offset, nbytes, flags);
+#else
-+#define lttng_sync_file_range(fd, offset, nbytes, flags) \
-+ fdatasync(fd);
++ return fdatasync(fd);
+#endif
-
- #elif defined(__FreeBSD__)
-
---
-1.7.10
+ }
+
+ #endif /* __linux__ */
+--
+1.8.0.3