summaryrefslogtreecommitdiffstats
path: root/package/dropbear/dropbear.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/dropbear/dropbear.mk')
-rw-r--r--package/dropbear/dropbear.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index e9da42df0..bced0ef4e 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -46,6 +46,14 @@ DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
DROPBEAR_DEPENDENCIES += zlib
endif
+ifneq ($(BR2_PACKAGE_DROPBEAR_WTMP),y)
+DROPBEAR_CONF_OPT += --disable-wtmp
+endif
+
+ifneq ($(BR2_PACKAGE_DROPBEAR_LASTLOG),y)
+DROPBEAR_CONF_OPT += --disable-lastlog
+endif
+
define DROPBEAR_INSTALL_TARGET_CMDS
$(INSTALL) -m 755 $(@D)/dropbearmulti $(TARGET_DIR)/usr/sbin/dropbear
for f in $(DROPBEAR_TARGET_BINS); do \