summaryrefslogtreecommitdiffstats
path: root/package/dhcpcd/dhcpcd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/dhcpcd/dhcpcd.mk')
-rw-r--r--package/dhcpcd/dhcpcd.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/package/dhcpcd/dhcpcd.mk b/package/dhcpcd/dhcpcd.mk
new file mode 100644
index 000000000..9d4a72beb
--- /dev/null
+++ b/package/dhcpcd/dhcpcd.mk
@@ -0,0 +1,42 @@
+################################################################################
+#
+# dhcpcd
+#
+################################################################################
+
+DHCPCD_VERSION = 5.6.7
+DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
+DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd/
+DHCPCD_LICENSE = BSD-2c
+
+ifeq ($(BR2_USE_MMU),)
+ DHCPCD_CONFIG_OPT += --disable-fork
+endif
+
+define DHCPCD_CONFIGURE_CMDS
+ (cd $(@D); \
+ ./configure \
+ --target=$(BR2_GCC_TARGET_ARCH) \
+ --os=linux \
+ $(DHCPCD_CONFIG_OPT) )
+endef
+
+define DHCPCD_BUILD_CMDS
+ $(MAKE) \
+ $(TARGET_CONFIGURE_OPTS) \
+ -C $(@D) all
+endef
+
+define DHCPCD_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/dhcpcd \
+ $(TARGET_DIR)/usr/bin/dhcpcd
+ $(INSTALL) -D -m 0644 $(@D)/dhcpcd.conf \
+ $(TARGET_DIR)/etc/dhcpcd.conf
+ $(INSTALL) -D -m 0755 $(@D)/dhcpcd-run-hooks \
+ $(TARGET_DIR)/libexec/dhcpcd-run-hooks
+endef
+
+# NOTE: Even though this package has a configure script, it is not generated
+# using the autotools, so we have to use the generic package infrastructure.
+
+$(eval $(call generic-package))