summaryrefslogtreecommitdiffstats
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index afa8d0e9f..069a86892 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -648,18 +648,16 @@ endef # GENTARGETS_INNER
################################################################################
# GENTARGETS -- the target generator macro for generic packages
#
-# Argument 1 is the package directory prefix [mandatory]
-# Argument 2 is the lowercase package name [mandatory]
-# Argument 3 is "target" or "host" [optional, default: "target"]
+# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
define GENTARGETS
-ifeq ($(3),host)
+ifeq ($(1),host)
# In the case of host packages, turn the package name "pkg" into "host-pkg"
-$(call GENTARGETS_INNER,$(3)-$(2),$(call UPPERCASE,$(3)-$(2)),$(call UPPERCASE,$(2)),$(1),host)
+$(call GENTARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
else
# In the case of target packages, keep the package name "pkg"
-$(call GENTARGETS_INNER,$(2),$(call UPPERCASE,$(2)),$(call UPPERCASE,$(2)),$(1),target)
+$(call GENTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
endif
endef