summaryrefslogtreecommitdiffstats
path: root/make/sed.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/sed.mk')
-rw-r--r--make/sed.mk18
1 files changed, 15 insertions, 3 deletions
diff --git a/make/sed.mk b/make/sed.mk
index f62d70d06..a6af02e4a 100644
--- a/make/sed.mk
+++ b/make/sed.mk
@@ -20,9 +20,21 @@ $(SED_DIR)/.unpacked: $(DL_DIR)/$(SED_SOURCE)
touch $(SED_DIR)/.unpacked
$(SED_DIR)/.configured: $(SED_DIR)/.unpacked
- (cd $(SED_DIR); autoconf; rm -f config.cache; CC=$(TARGET_CC1) \
- CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr --disable-nls \
- --mandir=/junk --infodir=/junk \
+ (cd $(SED_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
);
touch $(SED_DIR)/.configured