summaryrefslogtreecommitdiffstats
path: root/make/gdbserver.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/gdbserver.mk')
-rw-r--r--make/gdbserver.mk31
1 files changed, 21 insertions, 10 deletions
diff --git a/make/gdbserver.mk b/make/gdbserver.mk
index b31496fb6..cfc834a20 100644
--- a/make/gdbserver.mk
+++ b/make/gdbserver.mk
@@ -11,18 +11,29 @@ GDB_WDIR:=$(BUILD_DIR)/gdbserver
$(GDB_WDIR)/.configured: $(GDB_DIR)/.unpacked
- (cd $(GDB_WDIR); rm -rf config.cache; CC=$(TARGET_CC1) \
- AR=$(TARGET_CROSS)ar NM=$(TARGET_CROSS)nm \
- LD=$(TARGET_CROSS)ld AS=$(TARGET_CROSS)as \
- $(GDB_DIR)/gdb/gdbserver/configure --prefix=/usr \
- --includedir=$(STAGING_DIR)/include \
- --disable-nls --without-uiout --disable-gdbmi \
- --disable-tui --disable-gdbtk --without-x \
- --without-included-gettext);
+ (cd $(GDB_WDIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
+ --without-uiout --disable-gdbmi \
+ --disable-tui --disable-gdbtk --without-x \
+ --without-included-gettext \
+ );
touch $(GDB_WDIR)/.configured
$(GDB_DIR)/gdb/gdbserver/gdbserver: $(GDB_WDIR)/.configured
- make CC=$(TARGET_CC1) -C $(GDB_WDIR)
+ $(MAKE) CC=$(TARGET_CC1) -C $(GDB_WDIR)
$(STRIP) $(GDB_WDIR)/gdbserver
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_DIR)/gdb/gdbserver/gdbserver
@@ -31,7 +42,7 @@ $(TARGET_DIR)/usr/bin/gdbserver: $(GDB_DIR)/gdb/gdbserver/gdbserver
gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
gdbserver-clean:
- make -C $(GDB_WDIR) clean
+ $(MAKE) -C $(GDB_WDIR) clean
gdbserver-dirclean:
rm -rf $(GDB_WDIR)