summaryrefslogtreecommitdiffstats
path: root/make/findutils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/findutils.mk')
-rw-r--r--make/findutils.mk28
1 files changed, 17 insertions, 11 deletions
diff --git a/make/findutils.mk b/make/findutils.mk
index c32e98689..82727d4d4 100644
--- a/make/findutils.mk
+++ b/make/findutils.mk
@@ -23,10 +23,21 @@ $(FINDUTILS_DIR)/.unpacked: $(DL_DIR)/$(FINDUTILS_SOURCE)
touch $(FINDUTILS_DIR)/.unpacked
$(FINDUTILS_DIR)/.configured: $(FINDUTILS_DIR)/.unpacked
- (cd $(FINDUTILS_DIR); rm -f config.cache; CC=$(TARGET_CC1) \
- CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr --disable-nls \
- --mandir=/junk --infodir=/junk --localstatedir=/var/lib/locate \
- --libexecdir='$${prefix}/lib/locate' \
+ (cd $(FINDUTILS_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var/lib \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
);
touch $(FINDUTILS_DIR)/.configured
@@ -34,19 +45,14 @@ $(FINDUTILS_DIR)/$(FINDUTILS_BINARY): $(FINDUTILS_DIR)/.configured
$(MAKE) CC=$(TARGET_CC1) -C $(FINDUTILS_DIR)
$(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY): $(FINDUTILS_DIR)/$(FINDUTILS_BINARY)
- $(MAKE) prefix=$(TARGET_DIR)/usr exec_prefix=$(TARGET_DIR)/usr \
- bindir=$(TARGET_DIR)/usr/bin sbindir=$(TARGET_DIR)/usr/sbin \
- sysconfdir=$(TARGET_DIR)/usr/etc datadir=$(TARGET_DIR)/usr/share \
- includedir=$(TARGET_DIR)/usr/include libdir=$(TARGET_DIR)/usr/lib \
- localstatedir=$(TARGET_DIR)/var mandir=$(TARGET_DIR)/junk \
- infodir=$(TARGET_DIR)/junk CC=$(TARGET_CC1) -C $(FINDUTILS_DIR) install
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(FINDUTILS_DIR) install
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/junk
findutils: uclibc $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY)
findutils-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(FINDUTILS_DIR) uninstall
- -make -C $(FINDUTILS_DIR) clean
+ -$(MAKE) -C $(FINDUTILS_DIR) clean
findutils-dirclean:
rm -rf $(FINDUTILS_DIR)