summaryrefslogtreecommitdiffstats
path: root/make/autoconf.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/autoconf.mk')
-rw-r--r--make/autoconf.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/autoconf.mk b/make/autoconf.mk
index fe11b2c7d..2332f546a 100644
--- a/make/autoconf.mk
+++ b/make/autoconf.mk
@@ -21,9 +21,11 @@ $(AUTOCONF_DIR)/.unpacked: $(DL_DIR)/$(AUTOCONF_SOURCE)
$(AUTOCONF_DIR)/.configured: $(AUTOCONF_DIR)/.unpacked
(cd $(AUTOCONF_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) EMACS="no" \
+ $(TARGET_CONFIGURE_OPTS) EMACS="no" \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \